piCorePlayer 3.5.0

pCP Team 24 March 2018 pCP 3.5.0

The pCP Team has released an update for piCorePlayer.

Here are the major changes

  • RPi3B+ Support.
  • Kernel 4.14.26
  • RPi Firmware 14 Mar, 2018.
  • Moves to a 9.x piCore Base.
  • Moved from BusyBox modutils to kmod based modutils¬† (For better module dependency and configuration).
  • Updated to Squeezelite 1.8.7-1052, includes native DSD support.
  • Cirrus Logic (Wolfson) Card support.
  • HiFiBerryAmp2 Support.
  • Bluetooth Speaker Support.
  • Wireless AP Support (Tested with internal RPi Wifi).
  • Shairport-Sync 3.1.7, with added separate output settings.
  • Audio Kernel (armv7 only) is now a RT kernel /w Full Preemption.

Notes

  • Kernel’s in the 4.14.y and newer have increased the default required version of SMB and NFS mounts. 3.0 is now required by default, if your NAS does not support this, you will need to explicitly set vers=2.0¬† (or maybe even vers=1.0) on the mount options. See the information on network mount section of the LMS page.

Download

New images or insitu update are available. The released versions can be downloaded from here.

The pCP Team
Paul, Greg, Ralphy and Steen

The Software is provided "as is" without warranty of any kind, either express or implied, including without limitation any implied warranties of condition, uninterrupted use, merchantability, fitness for a particular purpose, or non-infringement.
Raspberry Pi is a trademark of the Raspberry Pi Foundation.